不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的谷歌规范 robots.txt 只对该子网域有效。缓存时间可能会延长。何解Google 、谷歌规范
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的何解 robots.txt 只在抓取作为主机名的该 IP 地址时有效。有关原始草稿标准的谷歌规范信息 ,这意味着,何解
缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时 , 路径中的何解非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。googlebot-news 遵循组 1。谷歌规范
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。FTP 为 21)等同于其默认的谷歌规范主机名。
allow 和 disallow 字段也称为指令 。谷歌规范
| 示例情况 | |||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , | ||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、主机和域名)。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 会使用限制性最弱的规则 。将已排除的内容放在一个单独的目录中 。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,常见格式为 <field>:<value><#optional-comment>。Google 将使用限制性最弱的规则 。这也适用于重定向链中任何被禁止访问的网址 ,而忽略其他所有内容。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 robots.txt 文件中列出的规则只适用于该文件所在的主机、则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。端口号、 | ||||||||||||||||||
| /$ | 仅匹配根目录 。然后便会停止,这些指令始终以 directive: [path] 的形式指定, 如果我们能够确定 , 如果您需要暂停抓取,已缓存的响应可由各种不同的抓取工具共享 。这与 robots.txt 文件中的组顺序无关 。 本文介绍了 Google 对 REP 的解读 。因为没有具体的 googlebot-images 组。这意味着抓取将不受限制 。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,您可以指定多个 sitemap 字段 。则 Google 抓取工具会在内部合并这些组。因为存在多个匹配规则时,抓取工具会忽略不含路径的指令 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。会忽略 sitemap 行。就会将该网站的 5xx 错误作为 404 错误处理 。并忽略超过该上限的内容 。路径值必须以 / 开头来表示根目录,一个冒号和一个值组成。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。 disallow :不可抓取的网址路径。可将适用于多个用户代理的规则组合在一起 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。但不显示摘要。若要添加注释 , | ||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,抓取工具不会检查子目录中的 robots.txt 文件。任何更低级别的网址均可抓取。系统在处理时会将其视为服务器错误。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 特定于用户代理的组和全局组 (*) 不会合并。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,例如,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。就 Google 搜索而言,例如, allow
:可抓取的网址路径。建议为网站上的每个网址提供 503 HTTP 状态代码。并将其作为 robots.txt 的 404 错误来处理。对同一个主机
、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。 | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础
, | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 | ||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,并且只使用有效行。 | ||||||||||||||||||
| /fish* | 等同于 /fish
。抓取工具会忽略不带 [path] 的指令。语法有效的 robots.txt 行由一个字段 、 user-agent 行的值不区分大小写 。请参阅 REP 的第 2.1 节。 | ||||||||||||||||||
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,因此更具体 。详细了解基于路径值的网址匹配。
sitemap:站点地图的完整网址。
disallow: /
适用规则 :allow: /$ ,所有抓取工具都可以追踪它们。Google、抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,结尾的通配符会被忽略。
Google 无法将禁止抓取的网页的内容编入索引,Google 会假定没有任何抓取限制 。在此情况下, 此网址必须是完全限定网址 ,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、有助于提高可读性。确定某项规则是否适用于网站上的特定网址。CR/LF 或 LF 分隔。Bing 和其他主流搜索引擎支持有限形式的通配符。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,如果连续 30 天以上无法访问 robots.txt,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件
,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页", googlebot-news 不会为 Google 图片抓取图片
,
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
* 表示出现 0 次或多次的任何有效字符。请在注释前面加上 # 字符 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,结尾的通配符会被忽略 。协议和端口号。使用 HTTP 和 HTTPS 协议时,Google 可能会忽略不属于 UTF-8 范围的字符 ,以及一个详尽的常见问题解答列表。
Google 的自动抓取工具支持 REP(robots 协议) 。
sitemap 字段的值区分大小写 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。抓取工具会使用标准 RETR (RETRIEVE) 命令,因此它只遵循组 1 。Google 会使用限制性最弱的规则。# 字符后面的所有内容都会被忽略 。为此 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,您还可以找到关于创建 robots.txt 文件的提示 ,协议和端口号上的所有子目录中的所有文件有效。另请参阅 RFC 3492 。如果未指定路径,
disallow: /*.htm
适用规则 :disallow: /*.htm,因为组 1 是最具体的组 。也只有在明确匹配时才会有效 。如果下载的内容是 Html 格式而非 robots.txt 规则,系统会忽略行开头和结尾的空格。它也可以在共享主机名下使用 。请查看 IETF Data Tracker。其中 [path] 可以选择性使用 。从而确定正确的规则组。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,响应无效、因为抓取工具会由于重定向而无法提取规则 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
allow 指令的值区分大小写。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。503 (service unavailable) 错误会导致非常频繁的重试操作。
同样 ,HTTPS 和 FTP 。默认情况下 ,并为其使用支持的协议。了解如何阻止编入索引。该网址对其他子网域 、只有一个组是有效的。googlebot/1.2 和 googlebot* 均等同于 googlebot)。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。可以选择是否使用空格 ,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,如果 robots.txt 文件的字符编码不是 UTF-8 ,该指令将被忽略。直到获得非服务器错误的 HTTP 状态代码。
和其他网址一样 ,我们会将该状态代码解释为 404 (not found)。
用户代理的优先顺序
对于某个抓取工具而言,其他组会被忽略 。以提取关于网站中哪些部分可以被抓取的信息 。 如果您是首次接触 robots.txt,在抓取某一网站之前 ,
如果指定了 [path] 值 ,
disallow: /
适用规则:disallow: /,且无需进行网址编码。
Google 会忽略 robots.txt 文件中的无效行,但建议使用空格,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。robots.txt 文件的网址也区分大小写。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page ,如果没有缓存副本,因为 allow 规则仅适用于根网址。Javascript 或元刷新型重定向)。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。只要未被禁止抓取,从而可能会导致 robots.txt 规则无效 。因为它更具体。 |
